Task could not find "AL.exe" using the SdkToolsPath ""

Hi I have Windows 10. Installed all SDK and Visual Studio.

Under VS 2015 project is build correclty.

But under team city I got error:


19:08:25][Step 3/9] C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets(2863,5): error MSB3086: Task could not find "AL.exe" using the SdkToolsPath "" or the registry key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v8.0A\WinSDK-NetFx40Tools-x86". Make sure the SdkToolsPath is set and the tool exists in the correct processor specific location under the SdkToolsPath and that the Microsoft Windows SDK is installed [C:\TeamCity\buildAgent\work\b3cf9cf503b49a7\Timeliner\TimePeriod\TimePeriod.Desktop.csproj]


Google issue but nothing helped.


Any thoughts?
7 comments

Hi Alex,

It seems that the issues is caused by environment misconfiguration and is not TeamCity related. For example see http://stackoverflow.com/questions/2986440/msbuild-on-ci-server-cant-find-al-exe.
If it does not help, then please try to investigate the issue using the guideline.

0

Well I tried a lot, but in Windows 10 - it seems it's not worked for Windows 10 SDK.

It's not working with that SDK. Do you have any thought how I can re-register .net for msbuild?

0

Guys - I'm trying to create a build agent server on 2012r2 using SDK 10 and without having VS installed.  The tests are failing because of a break in how the TC agent is looking for the SDK Tools directory.

I've tried configuring the TC build agent parameter to point to v10 tools but it insists on pointing to v8 tools directory registry key (which doesn't exist).  When I look at the parameter tab after the failure it shows the user defined variables matching the actual parameters on agent output but this isn't being supported by the logs

I've gone through the .net current version props file after looking at the .net ms targets file and haven't been able to identify how to specify the variable TargetFrameworkSDKToolsDirectory. 

I've found the Windows SDK Configuration Tool is available on our old 2008 build agent server but not 2012r2, so I'm unable to confirm the version this way.

There is nothing specific to target this on Google - have you seen this before? I'm sure this will become more and more common as we move away from 2008 and sdk 7.

0

Hi Thomas,

What TeamCity version do you use? There was the related bug fixed in 9.1.7 version: https://youtrack.jetbrains.com/issue/TW-44046.

0

Hi Alina, thanks for the comment.

so we're currently running on TeamCity Enterprise 9.1.7 build 37573

It does sound very similar in nature doesn't it.

 

thanks

tom

 

0

Add system env. variable TargetFrameworkSDKToolsDirectory

 

like this

TargetFrameworkSDKToolsDirectory=C:\Program Files (x86)\Microsoft SDKs\Windows\v10.0A\bin\NETFX 4.6.2 Tools

restart agent

2

@Golin Ivan, awesome, that fixed it.

0

Please sign in to leave a comment.