Multiple command line parameters not passed with .NET Process Runner

Hi,

I'm having trouble passing multiple command line parameters to an executable when using the .NET Process Runner. Screenshot shows my configuration. The problem is, only the build target (UnitTest) is forwarded to the FAKE.exe executable.

I've tried the following:
1) Put parameters on separate lines, like in the screenshot
     - Doesn't work, only the first line is passed to the executable
2) Put parameters on one line
     - Doesn't work, FAKE build script complains that Target "UnitTest --single-target --envvar buildCounter 12" doesn't exist.
     - I.e. multiple parameters on a single line are wrapped with quotes, making them a single parameter
3) Put parameters after the executable
     - Doesn't work, TeamCity complains that executable "FAKE.exe UnitTest --single-target --envvar buildCounter 12" doesn't exist
     - I.e. executable path is wrapped with quotes

If I run FAKE.exe with the Command Line runner, it works just fine, the parameters are passed as they are configured. But I need to run the UnitTest step using .NET Process Runner to get code coverage.

How on earth can I pass multiple parameters to my executable, when it is launched using the TeamCity's .NET Process Runner build step?

Regards,

    - Jussi



Attachment(s):
netProcessRunner.png
1 comment
Comment actions Permalink
Jussi Mattila, could you try to change the field "Edit command line" to the following:

UnitTest
–single-target
–envar
buildCounter
%build.Counter%

See https://youtrack.jetbrains.com/issue/TW-41625
0

Please sign in to leave a comment.