JetBrains Git Plugin?

I would like to be able to use the JetBrains-provided Git plugin as described here:

I was not able to download a build from the public teamcity server (always returns 404: The requested resource () is not available.), but I was able to clone the git repository and then build it using Ant. I'm using TeamCity Professional 4.5.2 (build 9029), so I copied "" to C:\Users\schilds\.BuildServer\plugins (and that is the directory as confirmed in the server settings:\Users\schilds\.BuildServer). Afterwards I restarted the TeamCity Webserver and Build Agent service processes.  However, no Git option is available when creating/updating a VCS root. Am I doing something wrong?

I have tried this on both Windows Vista and Windows Server 2003, and have tried running as both a user account and the SYSTEM account.

1 comment


What link produces 404 error?

We had some outages for the last several days, but now seems to function properly. Please try the link.

As to problems using your custom built plugin: are there any related loggin in the logs\teamcity-server.log  ? If you still cannot use neither downloaded plugin nor your, please restart the server, and send us the log for the server start, the plugin jar you are using and the listing of the directory the jar resides in.


Please sign in to leave a comment.