Cannot get Mercurial plugin to work

Hi,
can't figure out how to get the mercurial plugin to work. Followed instructions from http://www.jetbrains.net/confluence/display/TW/Mercurial

In teamcity UI I see:

: bt5
: Checking for changes
: Cannot resolve current sources revision. Check version control settiings
: Clearing temporary directory: C:\TeamCity\buildAgent\temp\buildTmp
: Checkout directory: C:\hg\yoolk
: Clean build enabled: removing old files from C:\hg\yoolk
: Getting project sources
: Loading changed files from server...
: Error while applying patch: Cannot resolve current sources revision. Check version control settiings
: Build finished


Log shows an expection:

DEBUG - jetbrains.buildServer.VCS - Cannot load vcs changes: jetbrains.buildServer.util.FileUtil.getCanonicalFile(Ljava/io/File;)Ljava/io/File;
java.lang.NoSuchMethodError: jetbrains.buildServer.util.FileUtil.getCanonicalFile(Ljava/io/File;)Ljava/io/File;
at jetbrains.buildServer.buildTriggers.vcs.mercurial.command.Settings.getDefaultWorkDir(Settings.java:139)
at jetbrains.buildServer.buildTriggers.vcs.mercurial.command.Settings.getWorkingDir(Settings.java:123)
at jetbrains.buildServer.buildTriggers.vcs.mercurial.MercurialVcsSupport.syncClonedRepository(MercurialVcsSupport.java:371)
at jetbrains.buildServer.buildTriggers.vcs.mercurial.MercurialVcsSupport.getCurrentVersion(MercurialVcsSupport.java:211)
at jetbrains.buildServer.buildTriggers.vcs.VcsChangesLoader.updateCurrentVersion(VcsChangesLoader.java:52)
at jetbrains.buildServer.buildTriggers.vcs.VcsChangesLoader.loadChanges(VcsChangesLoader.java:58)
at jetbrains.buildServer.vcs.impl.VcsManagerImpl.loadChanges(VcsManagerImpl.java:305)
at jetbrains.buildServer.vcs.impl.VcsManagerImpl.checkForModifications(VcsManagerImpl.java:400)
at jetbrains.buildServer.serverSide.impl.auth.SecuredVcsManager.checkForModifications(SecuredVcsManager.java:85)
at jetbrains.buildServer.serverSide.impl.VcsModificationChecker$1.run(VcsModificationChecker.java:5)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
at java.util.concurrent.FutureTask.run(FutureTask.java:123)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
at java.lang.Thread.run(Thread.java:595)

I'm running TeamCity Professional Version 3.1.1 (build 6828) , do I need to update that maybe? Or can I just get the package with this missing method or what might be wrong?

THanks a lot for any help,
Miika

4 comments
Comment actions Permalink

Thanks a lot Pavel, that fixed it, you rock!

0
Comment actions Permalink

We will appreciate your feedback about this plugin.

--
Pavel Sher

0
Comment actions Permalink

Hi all !
          I am new  to use the team city, I have a maven project to be checked for changes  from mercurial repo server, update changes, then build the project.

I am  successfull with building the maven project without configuring  mercurial in it.

But if i configure the mercurial & if i click test  connection ... it keeps going..... loading hours together. bt not gets  finished.

so  i cancelled, saved and clicked run button, then too it keeps running nt  ending.

there  is no problem with mercurial server n all bcoz i am using mercurial  through client for months with no problem.

I also tried with cvs as the vcs  its working bt Mercurial alone is problematic.

I am using tc 5.0.2.

Kindly help  me

I  hv attacted screen shot of cfg screens.



Attachment(s):
sc2.bmp
sc1.bmp
0

Please sign in to leave a comment.