Mercurial server side timeout

I've tried using the mercurial checkout on server, but it times out. This is most likely because the repo is quite large (>100M) which takes around 15 minutes to download from here.

Were is this repo being stored on the server, and can I clone it manually to give it something to start with.

TIA
C

3 comments
Comment actions Permalink

Repository is stored under the .BuildServer/system/caches directory. There must be a directory with hg_ prefix. You can clone your repository manually to this directory. I plan to add additional configuration parameter which will point to the manually cloned repository.

It would be nice if you send me teamcity-vcs.log from your server so that I could try to workaround this issue (you can send it to teamcity-feedback@jetbrains.com).

--
Pavel Sher

0
Comment actions Permalink

Hi all !
          I am new  to use the team city, I have a maven project to be checked for changes  from mercurial repo server, update changes, then build the project.

I am  successfull with building the maven project without configuring  mercurial in it.

But if i configure the mercurial & if i click test  connection ... it keeps going..... loading hours together. bt not gets  finished.

so   i cancelled, saved and clicked run button, then too it keeps running nt  ending.

there   is no problem with mercurial server n all bcoz i am using mercurial  through client for months with no problem.

I also tried with cvs as the vcs  its working bt Mercurial alone is problematic.

I am using tc 5.0.2.

Kindly help  me

I  hv attacted screen shot of cfg screens.



Attachment(s):
sc2.bmp
sc1.bmp
0
Comment actions Permalink

Sorry for delay, I missed you question.

TeamCity uses the same hg client. On the first run the process can take some time because the clone operation is performed. If repository is large or network connection is slow it may end up with timeout. To workaround this problem you can clone repository manually on the server and put path to the cloned repo to the text field: "Clone repository to"

0

Please sign in to leave a comment.