Problem SVN 1.6 and Visual Studio Plugin

Hello,

We are using TeamCity 7.1.4 (build 24331) for continuous integration with Visual Studio plugin. Pre-Commit is a really nice feature !
All the plugin configuration works fine (VS menu, login authentication to TC server, SVN configuration...) but the interoperability with SVN DIFF seems to be broken.
We are all using SVN 1.6 (collabnet + tortoise) and when we check working files modifications, the TeamCity for Visual Studio plugin display an error message (--internal-dif is not a recognized option) instead of textual diff.

I installed SVN 1.7 localy and the plugin works fine, but my developer team can't upgrade to that version.

Do you support SVN < 1.7 versions ?

Thanks for your support.

FX Boga

1 comment
Comment actions Permalink

Hello, François-Xavier
Yes we support old (< 1.7) Subversion versions. This particular bug was introduced while fixing http://youtrack.jetbrains.com/issue/TW-13156.
I've created separate issue for this bug. Feel free to watch / vote / comment it.
Sorry for the inconvenience!

0

Please sign in to leave a comment.