Cloud instances are disappearing when updating one of the clod profiles

Hello,   I am currently developing new cloud plugin, and I am facing some issues with stability.     When updating one of the cloud profiles, all instances of all profiles are being terminated.  Everything else other than that is working as expected.  In order to check the instances behavior I also installed Local Cloud plugin, and it acts the same – when updating one profile all instances of all profiles are disappearing.     This is how it looks like in the log file:     [2015-04-30 10:58:08,740]   INFO [uled executor 3] - .server.impl.CloudEventsLogger - Cloud instance has gone (is not reported by cloud profile): profileId=cp1, imageId=1, instanceId=1 [2015-04-30 10:58:08,756]   INFO [uled executor 3] - .server.impl.CloudEventsLogger - Cloud instance has gone (is not reported by cloud profile): profileId=cp4, imageId=1, instanceId=1 [2015-04-30 10:58:08,757]   INFO [io-9091-exec-10] - .server.impl.CloudEventsLogger - Profiles reloaded: count=4, integration is enabled      How can i solve it? is there some action i need to do to report each instance?I would really appreciate your help   Thanks,  Yarden
1 comment
Comment actions Permalink

Currently, when you update any cloud profile (or create a new one), the whole cloud model is reloaded. It means that all the existing cloud clients are disposed and then TC create new ones - one per cloud profile. If you don't catch up running instances during CloudClient initialization, the cloud core will report them as "has gone", since the call of CloudClient.getImages().iter.getInstances() does not report them.

This is a current design flaw and will be fixed in 9.1, but please also note that Cloud API might change in 9.1 and plugins developed for 9.0 might be incompatible with 9.1. I highly recommend you to wait until new Cloud API is introduced, which is likely to happen in one of the upcoming 9.1 EAPs (but definetely not 9.1 EAP1).

0

Please sign in to leave a comment.