server-api.jar - missing class: ExtensionHolder

Hi,

I'm trying to compile my plugin but I got this error:
[ERROR] class file for jetbrains.buildServer.ExtensionHolder not found

I'm using server-api-9.0.4-SNAPSHOT.jar and ExtensionHolder.class ideed missing, but still - other classes use this class (for example: ServerExtensionHolder.class )

am I missing something? is there known issue with this jar version?

2 comments

Hi,

ExtensionHolder resides in common-api.jar

BTW, why do you use "9.0.4-SNAPSHOT" version and not "9.0.3" or 9.1.4 which is the latest one?

0

Thank you Yegor :)

My mistake - I’m using 9.1.4 version

0

Please sign in to leave a comment.