Checkout times out when I specify location of git for windows git.exe

Using teamcity 10.0.1 (build 42078).  I'm checking out from a private repository on github.

 

When no path to git is set in the Edit VCS Root page, the checkout completes in about a minute.

When I set the "Path to Git:" to C:\Program Files\Git\cmd\git.exe , the checkout times out.  I'm using git for windows, version 2.10.0.windows.1.  I tried setting teamcity.git.idle.timeout.seconds to 3600 to test, and it still times out after an hour.  Is there something special about git for windows that breaks this process?  I tried both https: and git: style urls for the repository.

 

[C:\TeamCity\buildAgent\system\git\git-CC83F9A9.git]: "C:\Program Files\Git\cmd\git.exe" -c credential.helper=C:\TeamCity\buildAgent\temp\buildTmp\credHelper5061799105236277664.bat -c core.askpass=C:\TeamCity\buildAgent\temp\buildTmp\pass8970244154700423244.bat fetch --progress origin +refs/heads/BuildTest:refs/heads/BuildTest (10m)
[21:43:55][VCS Root: git@github.com:myprofile/myprivaterepo.git (BuildTest)] No output from git during 600 seconds. Try increasing idle timeout by setting parameter 'teamcity.git.idle.timeout.seconds' either in build or in agent configuration.
[21:43:55][Updating sources] Failed to perform checkout on agent: Timeout exception
1 comment

Hello Kristian,

Could you please attach full build log and logs from the build agent where checkout failed?

0

Please sign in to leave a comment.