Jetbrains Space Connection

Hi there!

I'm trying to configure my on-premise TeamCity instance to have a connection to my on-premise Space connection and am having a huge amount of trouble.

I have:

- (attempted to) create HTTPS certificates for TeamCity; It is a purely internal server so isn't using publicly owned domain names meaning that I can't use LetsEncrypt.  Adding these certificates means that TeamCity is now configured to operate over HTTPS but still flags an invalid certificate (presumably because it doesn't have a proper authority that has granted it).

- Created a Space application via TeamCity which failed because of:

An error occurred during sending request: SSLHandshakeException
Caused by: ValidatorException 

- Created a Space application manually and disabled SSL Verification. Added Authorizations (all of them because I was trying to get it to work) for both of my Projects and Global Authorizations. Configured the Authorization Code Flow and the Endpoint. Used the ClientID and ClientSecret to enter into TeamCity as a manually created connection.

TeamCity now shows:

Type: Manual connection

The associated Space application has no permissions.

URL: <URL to Space>
Client ID: <ClientId>

 

If I now go and try and create a new project in TeamCity, “Loading Space Connection” flashes up quickly and then goes away.

Any ideas how to troubleshoot where the problem is?

Does Space need to operate over HTTPS as well?

Do I need a way of having the certificates “trusted”?

What am I missing? :)

Thanks!

 

0
3 comments
Hi,

The unsecured connection to Space is not currently supported, so for the integration to work as expected, the HTTPS must also be configured for Space. Please refer to the Space documentation for the steps required for the configuration, depending on your installation method: https://www.jetbrains.com/help/space/space-on-premises-installation.html.

Best regards,
Anton
0

No problem. I can get certificates for it.

Can you please be more specific about where to find instructions for configuring HTTPS for Space?

For example, I have found this page:

https://www.jetbrains.com/help/space/configure-space-for-docker-compose-production-environment.html

However, the first instruction doesn’t seem to specifically apply to a Windows deployment.

“On the host machine, create the space.conf NGINX configuration file in the /etc/nginx/conf.d directory. For example:….”

Any help you can provide would be amazing!

Thanks!

Ben

0
Dear Ben,

This instruction assumes you are deploying Space using the Docker Compose on Linux. The path you mentioned is just a path to the nginx configuration file, which would be different for Windows. 
You can configure the reverse proxy for https communication on a Windows host as well. For this, use the Windows version of nginx and the config file for it. Please refer to the official nginx website for the downloads and documentation: https://nginx.org/en/docs/windows.html.
Alternatively, you can set up the nginx on a separate Docker container, which is also a valid option.

Just to add to this, for the integration to work, both Space and TeamCity must have https enabled. As you are using self-signed certificates, be sure to install the certificate into the JVM as a trusted certificate: https://www.jetbrains.com/help/teamcity/using-https-to-access-teamcity-server.html#Configuring+client+JVM+for+trusting+server+certificate.

It may also be helpful to add the certificates as trusted in Space: https://www.jetbrains.com/help/space/trusted-ssl-certificates.html.

Best regards,
Anton
0

Please sign in to leave a comment.