Remote login form broken after update

Running Teamcity on windows, after updating to 2023.11 build 147331, the login form is broken, see image below, there is no css styling and clicking the login using the domain link just reload the page, the continue with username/password link does nothing

In the browser console there are a bunch of errors showing 401 trying to load the css and js needed for the form

and js reference errors because the JS code doesn't exist.

Thankfully it still works if I remote desktop into the server and connect on localhost, so I am not locked out, but it is not as convenient as being able to access across the network.  I have tried restarting the service, the server and reinstalling TC, even in a different folder and nothing has changed.

Inspecting the failed requests in the browser the response headers show the team node id header, and there is no mention of anything being blocked in my anti virus software, so that makes me think the issue is at the team city side. The problem exists when accessing from other browsers and computers too.

Any ideas? thanks :)


I'm having similar issues, and worse in that builds are failing with the error  "Failed to publish artifacts: Artifacts URL is dedicated to storing artifacts and cannot be used to log in or serve other content.   To login manually go to "/login.html" page". I can however login using Edge browser (but not all of us can).


Furthermore, YouTrack integration is now broken. All requests from YouTrack are now reporting 401 Unauthorized:


@Steve Whitely, on the support ticket I logged, the solution that worked was to set internal property:


There was some change in 2023.11 related to serving of artifacts URL and this bled into other things. In particular, prior setting this, I found that using the FQDN for the host name in the browser URL did not work but the short host name did. Setting this property allowed both short and full host names to work.


Patrick Baker  Thank You! :) that has worked.

Leaving this link here to help anyone else / remind future me


This issue has more details and actual responses from Jetbrains technical staff.



Thanks for reporting this.

As it has been tracked in Multiple Problems after Upgrade to 2023.11 : TW-85409, we will close this ticket. If have any other questions, you can ask here or follow up on this issue in the tracer.


Please sign in to leave a comment.