Error collecting changes for VCS repository



The teamcity android build project seems to running fine for couple of months , but today it was unable to collect changes from repository , the vcs error is shows as "Error collecting changes for VCS repository '"git" {instance id=103, parent internal id=197, parent id=RpcAndroidApp_GitBugFix" ,  git -c core.askpass=C:\TeamCity\temp\pass8864275237380527866.bat -c credential.helper= fetch --progress --no-tags --recurse-submodules=no https://RpcAndroidApp.git +refs/heads/main:refs/heads/main command failed.
exit code: 128

Attached screenshot for the same , tried detaching and reattaching the vcs repo and created and new teamcity build project also.

Nothing seems to working till now , teamcity version is of latest.

kindly comment on this .

1 comment
Hi, have you tried to clear the cahces via Administration - Diagnostics -Caches,  and choosing to reset git's cache? If it doesn't help, please follow this link( to report the issue. To better and more swiftly assist in resolving your issue, we recommend including the following logs(teamcity-vcs.log,teamcity-vcs-states.log and teamcity-server.log) when posing your question. About how to get the server logs, please refer to our official document(

Please sign in to leave a comment.