Teamcity jmeter plugin issue

Hello Team,

I am facing an issue after setting up jmeter plugin in Teamcity. The plugin does not work as expected. Meaning, it does not show the option to create a build step after selecting jmeter plugin. I tried setting up Blazemeter and that worked well. 

IS there an on going issue with Jmeter plugin or is it just my environment?

Amit Goyal


Hello Amit,

Unfortunately, since this is a third-party plugin there is a little we could assist with in regards to that plugin. Basing on the repo, the plugin had no updates for 9 years - there were no drastic changes in the API as far as I know so it might be still working. I have not found any build step classes in the code, but it appears to add a build feature (see called Performance Remote Monitoring - you may check if you see one on your instance. 

If you would be willing to fork and update this plugin, and would need any assistance from our end, please do not hesitate to reach out. 


Please sign in to leave a comment.