Server upgrade to 2017.2 failed

I just tried to upgrade my installation of TeamCity 2017.1.5 to 2017.2.

After running the installer i noticed that the TeamCity Server Service was not installed.
I retried running the setup without success.

As the new server didn't get to run i could successfully revert to 2017.1.5.

I am wondering what went wrong as there was no indication of a problem.
Are there any issues open related to this?

4
8 comments

I'm experiencing the exact same problem here. Any help on this would be greatly appreciated.

1

Same exact issue. Tried installing on Windows Server 2012 R2 Standard. No TeamCity server service was registered. Tried twice, had to revert back to 2017.1.5

0

Okay, I was somehow able to resolve this with a lot of back and forth.

The first indication that something was wrong was that during the installation of 2017.2, the installer did not ask for a port number. Also, it did not open the web browser to connect to the Web UI, which had me stumped for a while.

After a time I figured out that all I had to do was type in "localhost" in the address bar (assuming I installed it on port 80, otherwise it would have been "localhost:[port number]", e.g. "localhost:1234", you cancheck the configured port in TeamCity\conf\server.xml, look for a line that beginns with "<Connector port=" ).

However, even that knowledge did not help me. Trying to connect to localhost with the port set to 80 returned me a 404 error, while trying to set it to another port and then conencting to that port allowed me to connect to the Web GUI from the server, but not from another computer (and really, I need it to run on port 80).

I next tried reverting to 2017.1.5, which did not work for quite some time.

Eventually, I figured out that port 80, which was the port that TeamCity was running on before, had been seized by the ReportServer service from MSSQL. After disabling that, I was able to successfully roll back to 2017.1.5.

After doing that, I tried upgrading to 2017.2 again, and this time, the installer asked me for a port. I specified port 80 and told it to run under the SYSTEM account, and miraculously, it worked this time around.

So I guess the advice I can give based on my experience is:

  • Try un- and reinstalling it
  • Make sure Port 80 is not in use, it that's the port you're using (there's a great documentation about possible port 80 snatchers here: https://stackoverflow.com/questions/30334074/)
  • Run the service under the SYSTEM account
2

Unfortunately, running under SYSTEM account is not an option for us.

0

So I finally figured it out. As I mentioned before 2017.2 installer did not register TeamCity Server Windows service. Fortunately it installed all the files needed to run the service, so I registered it manually and everything worked. Here is the command I used (run cmd.exe as admin):

sc create "TeamCity Server" "C:\TeamCity\bin\TeamCityService.exe jetservice /settings=C:\TeamCity\conf\teamcity-server-service.xml /LogFile=C:\TeamCity\logs\teamcity-winservice.log"

Obviously your install location maybe different so adjust the paths accordingly.

1

I just had the same issue updating here and also had to roll back. I also cannot use the System account.

0

I've encountered exactly similar issue. The problem was that there was no "repeat" in the installer step where you key-in TeamCity Server service credentials. In my case I input wrong domain name, it showed some error but then somehow it jumped to the team city build agent service credentials so it didn't install TeamCity Server service. So I had to reinstall it again in order to create TeamCity Server.

0

I finally succeeded with 2017.2.1.

The new installer also failed to register the TeamCity-service for the service-account i wanted to use.
But it could register it for the system account.
All i had to do is manually change the service's Log-On account in the Services-App.

 

0

Please sign in to leave a comment.