Build Configuration has failing build steps but is marked as a success.

Answered

I've got a build configuration that has many build steps with:

Execute: Even if some of the previous steps failed set.

I want all of the steps to run but I want the target to be marked as failed if any step fails.

 

I thought it would be marked as a fail if any of the steps exited with a non-zero exit code.

But it always returns successful no matter what.

I tried to make it fail by setting the "fail build on specefic text appear in log", the problem list indicate that the fail condition triggers and yet the target doesn't fail.

 

Does anyone know why?

 

 

Build steps:

 

Failure Conditions:



Typical result:



 

3
2 comments

Hi Carl-oscar.

The symbol right next to "Build problems" means that the issue has been somehow muted. This could be if some user has actually muted the problem, but can also happen if any of the build steps is reporting a service message forcing the build result to be a success. It's likely that the PcLint step is involved in the process, as the build result message is "0 pclint errors", which is not the default message for this kind of build, so probably that steps alters the result somehow.

Could you please check that no service message reporting success is passed? If that doesn't work, please provide us with a build log, and preferrably with the content of the buildcore.bat and any external references it might use. You can do it privately by using the "Submit a request" button on top of the page.

0

Hi Denis!

Thanks for you reply. It made me go through our MSbuild scripts and as you suspected I did find a place where we set the TC target success state explicitly. When I removed that the target started to behave as expected, problem solved.

 

Thank you!

0

Please sign in to leave a comment.