Disable HTTPS redirect via config file or database

While configuring HTTPS I changed the HTTPS redirect option from "Disabled" to "Only browser requests," only to discover afterward that the HTTPS version wasn't working correctly. The result is I keep getting redirected to an error page and obviously cannot change the setting back to "Disabled" because I can't access the admin portal. Is there a way to manually disable HTTPS redirect via config files or by manually changing a value in the database?


I was able to figure out the problem. TeamCity defaulted to port 443 but HTTP.sys, which runs in the background on Windows Server, was blocking TeamCity's access to the port. I temporarily disabled HTTP.sys and restarted the server. I was able to access TeamCity over HTTPS and change the port to an unused number.


I have this exact issue and cannot access the console page.
How can I disable HTTPS redirect from configuration files?


Hi! You can disable HTTPS redirects that you set up in TeamCity UI by editing the <TeamCity data directory>/config/_https/https-settings.xml file and replacing redirect-strategy="BROWSER_ONLY" with redirect-strategy="DISABLED", and restarting the server. I hope that helps!


Thanks! https-settings.xml update fixed my issue.


Please sign in to leave a comment.