.Net runner custom command fails in docker


I have a build step that uses the .Net runner to remove a project from the solution using the custom command "sln remove ..\docker-compose.dcproj" inside the mcr.microsoft.com/dotnet/sdk:6.0 Docker container.

Since upgrading TeamCity to 2022.10 (build 116751), it now fails with the following error


Hi, Installing the patched .NET plugin fixed it for me.

Hi, I've checked it with the default executable path, `dotnet`, and `/usr/bin/dotnet` on a Windows Docker host and Linux container. It looks like version 2022.10 works incorrectly with it. Running the same build configuration on a Linux Docker host worked for me. Please upvote/follow this bug for further updates: https://youtrack.jetbrains.com/issue/TW-78645.

Regarding the `/usr/bin/snap: not found`, I believe it comes from the Executables filed in the build step settings. It should either be left empty or set to tge `dotnet` executable path.


A quick update, as you can probably see from this comment in YouTrack, there is a patched .NET plugin version. Please install it as an external plugin to resolve the issue.


Please sign in to leave a comment.