How to use Git LFS when using Team City cloud?

Have created a "Git" VCS Root for a git-repo that holds both code and git LFS data. The problem is that it seems that the Team City Build Agent only does a standard "git clone" and does not do the necessary Git LFS-steps that are required when checking out a Git-LFS repo, like for instance: "git lfs install" and "git lfs checkout". So how do I tell Team City Cloud that it is a Git LFS repo and not a normal Git-repo?

2 comments
Comment actions Permalink

Turned out I had to install Git and Git LFS on the build agent. After that I added a build step that calls: "git lfs install" and then "git lfs pull" and it seems to work.

0
Comment actions Permalink

I am using a Mac mini with the M1 chip and Big Sur 11.5.2 which is the latest.

I am completely out of idea. Please help! I have configured and confirmed that git lfs works on agent. But it does not work when calling it from TeamCity.

If I run git lfs  --version from a terminal on the agent I get 

git-lfs/2.13.3 (GitHub; darwin arm64; go 1.16.5)

But if I run the same command line git lfs  --version from a build step on TeamCity I get 

  git: 'lfs' is not a git command. See 'git --help'.

And I have tried everything I can think of. It is  as if the Mac does not think Git LFS is available to TeamCity?

And yes I have tried every single combination of installing Git LFS including, but not limited to:

git-lfs install --system 

So what am I missing?

 

0

Please sign in to leave a comment.