'Starting TeamCity server' immediately followed by 'Server shutdown event received'

Answered

Team City has been working up until recently, and now the server seems to immediately shutdown after starting. Below is my teamcity-server.log.

[2021-07-05 12:47:01,673] INFO - jetbrains.buildServer.STARTUP - ===========================================================
[2021-07-05 12:47:01,674] INFO - jetbrains.buildServer.STARTUP - Starting TeamCity server
[2021-07-05 12:47:01,988] INFO - jetbrains.buildServer.STARTUP - Server shutdown event received
[2021-07-05 12:47:02,437] INFO - jetbrains.buildServer.STARTUP - TeamCity version: 2020.2.3 (build 86002), data format version 958
[2021-07-05 12:47:02,455] INFO - jetbrains.buildServer.STARTUP - OS: Mac OS X, version 10.13.6, x86_64, Current user: root, Time zone: BST (UTC+01:00)
[2021-07-05 12:47:02,455] INFO - jetbrains.buildServer.STARTUP - Java: 1.8.0_282, OpenJDK 64-Bit Server VM (25.282-b08, mixed mode), OpenJDK Runtime Environment (1.8.0_282-b08), Amazon.com Inc.; JVM parameters: -Djava.util.logging.config.file=/Library/TeamCity/conf/logging.properties -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djdk.tls.ephemeralDHKeySize=2048 -Djava.protocol.handler.pkgs=org.apache.catalina.webresources -Dorg.apache.catalina.security.SecurityListener.UMASK=0027 -Xmx1024m -Dteamcity.configuration.path=../conf/teamcity-startup.properties -Dlog4j.configuration=file:/Library/TeamCity/bin/../conf/teamcity-server-log4j.xml -Dteamcity_logs=/Library/TeamCity/bin/../logs -Djava.awt.headless=true -Dignore.endorsed.dirs= -Dcatalina.base=/Library/TeamCity -Dcatalina.home=/Library/TeamCity -Djava.io.tmpdir=/Library/TeamCity/temp
[2021-07-05 12:47:02,457] INFO - jetbrains.buildServer.STARTUP - Garbage collection: PS Scavenge, PS MarkSweep
[2021-07-05 12:47:02,458] INFO - jetbrains.buildServer.STARTUP - Web server version: Apache Tomcat/8.5.61
[2021-07-05 12:47:02,461] INFO - jetbrains.buildServer.STARTUP - Server IP address: 192.168.0.87
[2021-07-05 12:47:02,465] INFO - jetbrains.buildServer.STARTUP - Web server ports: 8111 (protocol: HTTP/1.1, scheme: http), 8105 (shutdown port)
[2021-07-05 12:47:02,465] INFO - jetbrains.buildServer.STARTUP - Context path: "/", servlet real path: "/Library/TeamCity/webapps/ROOT"
[2021-07-05 12:47:02,493] INFO - jetbrains.buildServer.STARTUP - TeamCity distribution type: tar.gz
[2021-07-05 12:47:02,493] INFO - jetbrains.buildServer.STARTUP - TeamCity server node id: MAIN_SERVER
[2021-07-05 12:47:02,506] INFO - jetbrains.buildServer.STARTUP - Version file lock was successfully obtained: /Library/TeamCity/webapps/ROOT/BUILD_86002
[2021-07-05 12:47:02,550] INFO - jetbrains.buildServer.STARTUP - Current stage: TeamCity server is shutting down
[2021-07-05 12:47:02,550] INFO - jetbrains.buildServer.STARTUP - Stopping the main application
[2021-07-05 12:47:02,550] INFO - jetbrains.buildServer.STARTUP - The main servlet is not initialized, nothing to shut down.
[2021-07-05 12:47:02,552] INFO - jetbrains.buildServer.STARTUP - Version file lock was released: /Library/TeamCity/webapps/ROOT/BUILD_86002
[2021-07-05 12:47:02,555] INFO - jetbrains.buildServer.STARTUP - Server shutdown complete. Uptime was 1s
[2021-07-05 12:47:22,897] INFO - jetbrains.buildServer.STARTUP - Path to the startup configuration file: /Library/TeamCity/bin/../conf/teamcity-startup.properties
[2021-07-05 12:47:23,572] INFO - jetbrains.buildServer.SERVER - Using logs directory "/Library/TeamCity/logs"
[2021-07-05 12:47:23,759] INFO - jetbrains.buildServer.STARTUP -
4 comments
Comment actions Permalink

I had to reinstall MacOS and the issue is now resolved.

0
Comment actions Permalink

Just to say after restarting today the issue reappeared. Same log as above. Server shuts down immediately after starting.

0
Comment actions Permalink

Hello,

It looks like something triggers server shutdown. How do you start the server?

0
Comment actions Permalink

Same issue for me.

0

Please sign in to leave a comment.