Azure DevOps Pull Request Integration

I've set up the Pull Request Build Feature on a build. The build automatically triggers correctly when a merge is completed, but not when a Pull Request created. See the attached images for my configuration. For the Pull Request Build Feature I'm using a Personal Access Token from Azure DevOps with Full Access (just to be sure). Testing the connection works.

I have no idea what I'm missing, any help would be greatly appreciated.

Comment actions Permalink
Official comment

Hi Kaboomer13, it seems the branch filter in your trigger is configured to only trigger builds in the `wrangler` branch, but in pull request branches. 

Comment actions Permalink

Is there any support from JetBrains? We pay for a professional license so we're not permitted to submit issues to their support desk.

Comment actions Permalink

Thanks for your response, Anton. I've done that now, as seen here:


I hadn't done it before since the instructions for the build feature did not indicate that it was required. My incorrect thinking was that the build feature itself would serve as the trigger.

Unfortunately, it still isn't working. I wonder if this has something to do with it. When I look at the Changes window the pull request does appear to be there, but there doesn't appear to be any changed files included even though the pull request contains one changed file and one new file.

The help article for the Pull Request build feature indicates that the pull request branch should not be added to the VCS settings, which I have not done.


Comment actions Permalink

I worked on this exact  integration for hours today and finally got it to work. Try this:

  • In VCS root provide a Default branch and NO Branch specifications.
  • On Version Control Settings page make sure there are NO Branch Filters defined (this caused most of the problems)
  • Define your PR Build Feature.  We limited ours by target branch using +:/refs/heads/Development (then QA and Release too)
  • Our trigger has only one checkbox checked, "Queued build can be replaced with more recent build".  Also, we have no other values in any other fields.

Once I did that, it all worked as expected!


Please sign in to leave a comment.