TeamCity proxy doesn't work;

my TeamCity config a GitHub project, which connection is very poor, because we are in china,  I have set hk proxy . however it still happened:

Failed to collect changes, error: List remote refs failed: org.apache.http.conn.ConnectTimeoutException: Connect to github.com:443 [github.com/13.229.188.59] failed: connect timed out, VCS root: "https://github.com/******#refs/heads/master" {instance id=26, parent internal id=1, parent id=*****, description: "https://github.com/*****o#refs/heads/master"}
1 comment
Comment actions Permalink

The git processes in TeamCity have their own proxy settings. Please configure the following internal properties:

teamcity.git.sshProxyType
Type of SSH proxy, supported values: httpsocks4socks5. Keep in mind that socks4 proxy cannot resolve remote host names, so if you get an UnknownHostException, either switch to socks5 or add an entry for your git server into the hosts file on the TeamCity server machine.

teamcity.git.sshProxyHost

teamcity.git.sshProxyPort

For additional information on git properties, please visit our documentation at https://www.jetbrains.com/help/teamcity/git.html#internalProperties. 

0

Please sign in to leave a comment.