buildStageDuration:buildStepRUNNER always showing 0ms


On our statistics tab any chart showing a buildStageDuration:buildStepRunner shows 0ms no matter what step it is. Also our Build Duration (Excluding Checkout) shows 0ms but the Build Time (All Stages) shows the correct time. Here is a screen shot of what our graphs are showing.

These graphs were working but abruptly stopped working after we had to restore our build machine using an export I made of the root project.


Hi Max. Please explain in a bit more detail how you performed the export and import of the projects. Was that was the 'Export project' option under the Root project settings, and then Projects Import option on a new server? Was the database restored to the new server? Is the build step duration missing even for the new builds?

Please note that projects import has some limitations and doesn't import all data the backup/restore functionality does.

As a side note, the version of TeamCity you are using has reached the End of support stage. I'd strongly recommend upgrading due to patched security issues, let alone other fixes and improvements. 



Anatoly Cherenkov Sorry it took me so long to get back to this. Yes when I made the export it was done using the Export project under the root project settings. The database was not restored to the new server, we lost the database but I happen to have a export of all our projects I had taken some months before we lost them. The new build are also missing the build durations.

Thank you for the reminder about updating, we want to update but haven't had the resources to do it yet. I also found today that when I hover over the Progress bar it will show the estimated time. Before we lost everything it would show time remaining on the progress bar but since then it stopped showing it.

Also even new projects we added that did not exist when we imported have all these issues.


Anatoly Cherenkov Is this issue resolved in a particular version of teamcity? I asked on the ticket itself but no response yet.


Please sign in to leave a comment.