Commit Status Publisher to BitBucker Server does not work for some project

I enabled commit-status preset in diagnostics and I see in the teamcity-commit-status.log entries that pull request build was started and that the build finished. But when I go to the bitbucket UI for this PR, no build results can be seen. No errors in the teamcity-commit-status.log reported.

Surprisingly, there are some other TeamCity config and some other Bitbucket repositories, and Commit Status Publisher works well.

The project is very simple, it has just 1 vcs.

Unforutnately, teamcity-commit-status.log is not informative and does NOT include actul REST URLS that were called so that I could check that it formed the API call properly.

Ideas?

5 comments
Comment actions Permalink
Official comment

Hi Vyacheslav, 

May I ask if you have a multi-node configuration of TeamCity server and also what version of Bitbucket Server do you use?

Thanks!

Comment actions Permalink

The issue appeared immediately after upgrade from TeamCity-2020.1.5 to TeamCity-2020.2.1

I see there were significant changes in the Commit Status Publisher plugin in this version
https://youtrack.jetbrains.com/issue/TW-66627

 

0
Comment actions Permalink

Hi Vyachelav, 

I don't think that the mentioned task has any effect on the Bitbucket repositories. We have another similar bug reported; please check TW-69519. Could you please also check teamcity-vcs.log for any problems reported? Do you see any errors in it? You can provide any additional information on the issue that I just mentioned. 

Thank you!

0
Comment actions Permalink

We use just one instance of TeamCity server. I don't see any issues in the teamcity logs. 

I have attached the logs to https://youtrack.jetbrains.com/issue/TW-69519

 

0
Comment actions Permalink

Hi

We have the same issue. Bitbucket don't get notified about the build status anymore.. Did you already found a solution?

Regards,

0

Please sign in to leave a comment.