MIgration of Team City to MSSQL Express 2019

Answered

Hi 

I have installed MS SQL 2019 express and Team City. However, when it gets to the point of connecting to the MSSQL Database the authentication is failing. I have tried using Windows Authentication and SQL authentication. But it will not connect with the JDBC driver. 

The message I get is this - 

"

The connection to the host TCSERVER, named instance tcserver\sqlexpress failed. Error: "java.net.SocketTimeoutException: 
Receive timed out". Verify the server and instance names and check that no firewall is blocking UDP traffic to port 1434.
For SQL Server 2005 or later, verify that the SQL Server Browser Service is running on the
host.: com.microsoft.sqlserver.jdbc.SQLServerException: The connection to the host TCSERVER, named instance tcserver\sqlexpress
failed. Error: "java.net.SocketTimeoutException: Receive timed out".
Verify the server and instance names and check that no firewall is blocking UDP traffic to port 1434.
For SQL Server 2005 or later, verify that the SQL Server Browser Service is running on the host.

I used this article as reference -  https://www.jetbrains.com/help/teamcity/setting-up-teamcity-with-ms-sql-server.html#Additional+settings+for+Windows+authentication+%28MS+SQL+integrated+security%29

I am assuming MSSQL 2019 Express is supported. 

Can anyone help? 

Regards 

Yamin

1 comment
Comment actions Permalink

Hi,

From the error, it seems your TeamCity server is unable to reach the database. Please check the connection settings to ensure you have entered them correctly and that the database is running on TCSERVER and accepting connections on port 1434. If the settings are correct, please check that you are able to connect to the database from the TeamCity server outside of TeamCity? 

I can confirm MS SQL Express is supported. Please see a complete list of supported databases in our documentation here: https://www.jetbrains.com/help/teamcity/supported-platforms-and-environments.html#Supported+Databases

0

Please sign in to leave a comment.