Agent has unregistered (will upgrade)

Answered

I'm trying to evaluate teamcity and i cannot for the life of me figure out this problem. I have tried everything i can find on the internet and in the forums here. I can't figure out how to attach log directly here, so i used the webform upload.

 

2020_07_08_3w224P29gefbMwp9

That's the id, logs-agent.zip and logs-server.zip

Thank you!

4 comments
Comment actions Permalink

Hi,

I've been looking over your logs, thank you for taking the time to upload them. The update process does not appear to be working properly for some reason. The issue is that the build agent does not find the required plugins, so it downloads them from your TeamCity server. This part seems to be working:

[2020-07-08 14:12:54,825] INFO - jetbrains.buildServer.AGENT - Downloading http://localhost:7800/update/plugins/agentSystemInfo.zip ==> C:\Users\xxx\Desktop\TC_Test\BuildAgent\update\plugins\agentSystemInfo.zip
[2020-07-08 14:12:54,855] INFO - jetbrains.buildServer.AGENT - The file C:\Users\xxx\Desktop\TC_Test\BuildAgent\update\plugins\agentSystemInfo.zip has been downloaded successfully, file hash: SHA-1zlpEZ8908fK7DOaUOMfK0CmzbZs=

We can see the plugin is downloaded successfully. However, during the upgrade, the file copy is skipped for unknown reasons. I have not seen before:

[2020-07-08 14:18:17,866] DEBUG - buildServer.agent.LauncherUtil - Copy from C:\Users\xxx\Desktop\TC_Test\BuildAgent\update\plugins to C:\Users\xxx\Desktop\TC_Test\BuildAgent\plugins 
[2020-07-08 14:18:17,866] DEBUG - buildServer.agent.LauncherUtil - Skipped copy from C:\Users\xxx\Desktop\TC_Test\BuildAgent\update\plugins to C:\Users\xxx\Desktop\TC_Test\BuildAgent\plugins

Since the file copy was skipped, it subsequently is not found on the next build agent startup following the update:

[2020-07-08 14:17:32,541] WARN - ent.plugins.AgentPluginsLoader - Plugin agentSystemInfo.zip was not found 

Can you please tell me if you used the Windows installer or the ZIP to install this agent and are you running it as a Windows service? Does the user which runs the agent have enough permissions to copy files to the destination?  

Thanks,

Eric

0
Comment actions Permalink

Hi Eric,

Thanks for the insight, the issue makes sense now!

I used the installer. It is running as a windows service and both the agent and server on the same pc. I have uninstalled and reinstalled using both the "system" account and our administrator account, I saw that message on each attempt. 

Orginally I installed it on another drive (not the c:\), thinking that might be the issue, but then i tried to install it on the desktop this last time, same result as you can see.

I had also tried running the agent.bat file using an elevated command prompt, but same thing.

I had also gone to the folder properties and verified the system and admin account have full read/write privileges to this folder.

BTW, It is running on a windows server 2012 R2, although that shouldn't affect what we are seeing.

Should i just try to copy them manually?

Thank you!

0
Comment actions Permalink

Hi Eric,

 

Copying the files manually did not seem to do the trick.

 

Got any more ideas?


Thanks!

0
Comment actions Permalink

I have not been able to replicate your issue. Can you tell me if this file exists? <build agent home>\conf\teamcity-upgrade-error.log

0

Please sign in to leave a comment.