Windows LDAP login broke after upgrading to Version 2019.2 (build 71499)

Completed

I have Teamcity configured to use Windows Active directory domain and it was working fine before the update. Now I am unable to login after logging out. Users who did not logout are able to use Teamcity normally. Please let me know how can I resolve this error.

I have verified the auth-config.xml and it is fine. I also have YouTrack in the same machine which is working fine with domain login.

These are the error messages I found in the log file.

[2019-12-18 14:47:24,394] INFO [1, no auth; http-nio-86-exec-7] - Login for username "ramnish" failed, see details below
[2019-12-18 14:47:24,394] INFO [1, no auth; http-nio-86-exec-7] - Login for user "ramnish" failed for module "Special Users" (jetbrains.buildServer.serverSide.impl.auth.SpecialUsersLoginModule), took < 1ms. Details: jetbrains.buildServer.serverSide.auth.TeamCityFailedLoginException: Not a special user or login as special user is not allowed
[2019-12-18 14:47:24,394] WARN [1, no auth; http-nio-86-exec-7] - Login for user "ramnish" failed for module "Microsoft Windows domain" (jetbrains.buildServer.serverSide.impl.auth.NTDomainLoginModule), took < 1ms. Details: javax.security.auth.login.LoginException: java.lang.IllegalStateException: Shaj did not initialize correctly.
at com.cenqua.shaj.Authenticator.getDefault(Authenticator.java:22)
at com.cenqua.shaj.Shaj.checkPassword(Shaj.java:81)

2 comments
Comment actions Permalink

Hi Ramnish.

It seems that you have obsolete settings configured. Could you please check <TeamCity data directory>/config/ntlm-config.properties file? "ntlm.compatibilityMode" and "teamcity.ntlm.use.jcifs" shouldn't be configured.

We have the related issue in YouTrack. Since version 2019.2 we bundle 64x Java, that's why you hit this error after an upgrade.

1
Comment actions Permalink

It fixed the login issue. Thanks.

0

Please sign in to leave a comment.