Build agent for WPF NetCore 3.0 App

Hello

I'm new to TeamCity. I've just installed on my machine where I have VS2019 installed and let it detect the correct parameters from my github repository that contains a small WPF app built with Netcore 3.0. Since there's no compatible build agent I can't run any build but I don't know how to provide the correct build agent (i have tried also manually). Any hint?

Gianpaolo 

4 comments
Comment actions Permalink

Hi Gianpaolo,

I'm happy to help you sort this out. To begin, can you tell me a little bit more about your configuration? Are both the TeamCity Server and Agent installed on the same machine, and can you clarify that the machine with the Agent has VS2019 installed?

If you could go to your TeamCity Server and look at the Build Queue and then click on the link that says "No Agents", it should list the unmet requirements. Could you tell me what is listed there?

0
Comment actions Permalink

Hi Eric,

thanks a lot.

Yes, everything is installed on my win10 laptop with vs2019 community edition.

Unmet requirement is this:

blu20791(disabled)

Unmet requirements:
  • MSBuildTools12.0_x86_Path exists

is it looking for the wrong MSBuild tool?

(I wrote netcore 3.1 in the title but its' netcore 3.0)

 

EDIT: it seems I have to specify this is visual studio 2019?

Build Step: Visual Studio (sln) edit »

Step 1:
Runner type: Visual Studio (sln) (Microsoft Visual Studio solution (.sln) runner)
Execute: 
If all previous steps finished successfully
Solution file path: Wpfasync.sln
Working directory: same as checkout directory
Visual Studio: Microsoft Visual Studio 2013
 

 

Gianpaolo

0
Comment actions Permalink

IT WORKS!

I have changed the build steps and created a manual step, seems it's ok :-)

 

0
Comment actions Permalink

Thank you for writing back to let me know, I'm so glad you figured this out and I hope you enjoy TeamCity!

0

Please sign in to leave a comment.