Gtilab integration with TeamCity 2019.1

Hi,

I followed the video guide at https://youtu.be/aE150gCfQyI but I'm having problems when I click Test connection on Pull request build feature configuration. The error is:

Pull request information retrieval I/O error: Pull request information retrieval failure due to HTTP error, status code 404: Not Found
5 comments
Comment actions Permalink

Hi Pavel,

Thanks for reporting this.

Yes this indeed looks like a bug. Is `project` a group and `server` a subgroup of it, while `citest` is a project in that subgroup?


0
Comment actions Permalink

Hi,

yes, the repository structure is exactly as you say. I tried to create project/citest2 for test and Test connection succeeds for it. So it really seems like a problem with subgroups.

Pavel

 

0
Comment actions Permalink

We have reproduced the issue and are working on fixing it now. You can watch its progress here: https://youtrack.jetbrains.com/issue/TW-60731
The fixed version will be released with TeamCity 2019.1.1 but we will probably be able to provide you with an updated version of the plugin itself earlier than that. 

0
Comment actions Permalink

That would be perfect, thanks.

0
Comment actions Permalink

Hi Pavel, I have attached a version of the plugin with this issue fixed to that issue in our issue tracker. You can download it to your plugins directory and try if it fixes the issue in your case. Of course when it comes to production installations we cannot recommend using this version of the plugin as another fully verified version of it with this and some other fixes will be released as part of TeamCity 2019.1.1 bugfix release. 

0

Please sign in to leave a comment.