Compilation failed Teamcity 5.1, metadata file missing


This problem is the one that many ppl had before but there are few answers to find that could help.

I have succesfully intalled teamcity 5.1 on virtual server running Wnidows Server 2008.
On other machine we have Team Foundation Server 2008.

We have one solution with 47 projects where most of them have referances to each other.
Problem is that when trying to build solution somehow dll needed is missing or not compiled. There are no erros compiling with vs2008.

I have read other posts here with someone suggesting to change my Target option to Build - in stead of Rebuild which is by default but it didn't help.

I will post 2 pics to see my build config and error message.

Can someone please guide me a bit to solve this. We are in desperate need of working CI and teamcity seams like very nice solution.



Comment actions Permalink

Could you please attach build log.

Comment actions Permalink

Yes and thanks for trying to help.

Here is build log for last failed build.

Usually I compile my solution via visual studio so I never touch config files.

Comment actions Permalink

Come on guys.

This should be easy problem to fix.

Is it csproj files that are cause of the problem?

Do I have to choose "Copy local" for all referenced projects in order to build sln? That would be overkill for TFS.

Can someone please help- i am stuck here.


Comment actions Permalink

Ok I got this finaly right.

Problem was in front of my eyes all the time, and I dont know how I manage to oversee this.

Since we have 47 projects in solution so we dont build all in debug mode every time. So some of projects were unchecked in Buld configuration manager.

Hence missing dlls - we explicitly unchecked this projects that are not needed compiling on dev server.

I can only hope that this saves some time to other beginners..

Next challenge is to get MStest running on TeamCity. That is not going to be this easy to fix .

Comment actions Permalink

Find out reason not compiling all prs.


Please sign in to leave a comment.