Resolving hosts from .ssh/config file in git plugin

We are using hosts in the .ssh/config file to set identity files for our remotes.  For instance a .ssh/config would look something like this:

Host homer-at-foo
       User homer
       IdentityFile ~/.ssh/

TeamCity appears to honor this during the actual clone/pull of source when running a build but when doing things such as checking for changes, testing the connection for the VCS root and looking up submodule information. This is a problem for us because all of our submodules point through the host aliases found in the conf.  Has anybody found a way around this?


Seth, what version of TeamCity and git plugin do you use?


Sorry, I completely forgot to give version numbers.  I have tried this using the git plugin that ships with TeamCity version  5.1.4 (build 13550).  I have also tried with version 6.0 EAP (build 15638) since I happened to have that version up an running to test some other things out in the EAP.


Seth, I succeed to reproduce problem with submodules in latest TeamCity 6.0 EAP and created an issue: TW-14189.


Please sign in to leave a comment.