Subversion SSL certificate problem

I use TeamCity        Professional Version 4.0 (build 8080) and try to configure VCS Root via web, but "Test connection" says "svn: Authentication required for '<https://svn.lan:443>'"

My certificate is pointed out in "C:\Documents and Settings\User\Application Data\Subversion\servers":
ssl-client-cert-file = D:\User\servers\SVN\user.pfx
ssl-client-cert-password = qwerty
And this is normally works in IntelliJ IDEA, but I don't understand, what I should do in TeamCity for using this certificate.

Comment actions Permalink


  Please check that TeamCity cannot get sources (there is a chance that Test Connection doesn't work but source checkout works).
  Please also make sure that "Use default config directory" is selected and points to the valid settings directory.

  If this won't help, please enable SVN debug logs , clear TeamCity/logs directory, restart TeamCity, try Test Connection, and send us
  logs from TeamCity/log directory. We'll try to investigate the problem.

  You may also try the latest TeamCity EAP build, because it has an updated version of SVNKit library (1.2.1) and it may already have a fix.

  Kind regards,

Comment actions Permalink

Thanks for reply.
I just now sent e-mail with logs and screenshots to you. Nothing has helped.

Comment actions Permalink

I encountered a similar problem, our SVN server uses NTLM to authenticate and SVNKit wasn't configured for this.

I fixed it by adding
to all the places I could find in the batch files in TeamCity\bin and running the server via the batch file rather than the server
discusses the issue and suggests a fix which unfortunately didn't seem to work for me.

I really think that the NTLM flag should be set by default, it's obviously not a totally uncommon problem for SVN users.


Comment actions Permalink


I'm having the same issue and it doesn't seem to want to work, regardless what I change.

Can you give specific instructions on what you changed.


Comment actions Permalink

Hello Callon,

  Could you please provide details of your non-working configuration:

  - Subversion URL type
  - Authentication scheme
  - Whether do you use externals
  - Logs as described by this link in our docs

  Thanks for your help,

Comment actions Permalink


I got my TeamCity server to work. I got some assistance from support. They directed me to add 2 configuration options to TomCat and another config file.

Thanks for your support though.


Comment actions Permalink

Hi Callon,

Could you post the information on which files to adjust and how, I'm still using my batch file fix and I'm sure others would appreciate the information also

Many thanks,

Comment actions Permalink

No problem. So to recap, my issue is that we're using NTLM authentication on our Subversion server. To address this issue I had to do 2 steps.

Step 1: Update the wrapper.conf file:

- Browse to your TeamCity \buildAgent\launcher\conf folder.
- Backup and then edit your 'wrapper.conf' file.
- Add an entry to the # TeamCity agent JVM parameters.

Here is the complete section. Notice that you have to insert this line before the '.AgentMain entry' and you will need to renumber the parameters.

# TeamCity agent JVM parameters
# The next line can be removed (and the rest of the lines renumbered) to prevent memory dumps on OutOfMemoryErrors
# Preventing process exiting on user log off
# Uncomment the next line (insert the number instead of "N" and renumber the rest of the lines) to improve JVM performance
# TeamCity agent parameters


Step 2: Update your TomCat configuration dialog:


- Open a command prompt and change directory to your TeamCity\bin folder.
- Note: case sensative!!!
- run the following: 'tomcat6w.exe //ES//TeamCity'
- Go to Options and add the following:


- Then restart your TeamCity Server and Agent services.

That should do the trick. This is what solved me issue. I hope this helps.


Comment actions Permalink

Hi Donz,

I hope you have removed this gap since I have the same problem.

Would you like to share something about it? I'll appreciate it.


Please sign in to leave a comment.