Tag failure on branches

Hi all,
  I'm trying to tag on a branch and having quite a few problems.  Here is my VCS configuration.


SVN Root
https://redmine.foo.com/svn/app/server

within app/server I have the following directories

trunk
branches
tags

Tag rules
+:trunk=>tags
+:branches/build-2.5.3-38-hotfix=>tags (I'd like to be able to use +:branches/**=>tags, is this possible?)


The following checkout rules work for tagging

+:trunk=>.

This checkout rule fails, but the build itself runs fine

+:branches/build-2.5.3-38-hotfix=>.

Here is my exact error message


Labeling process failed: No labeling rules found for checkout rules branches/build-2.5.3-38-hotfix=>


I have obviously configured something incorrectly, but I'm not sure what I've done wrong.  Any help would be greatly appreciated.

Thanks,
Todd

3 comments

Hello Todd,

  Given that checkout rule and tag rule for trunk work ok, there should not be a problem with the branch as well. So there may be some bug .
  Please try using the following tag rule:

  /branches/build-2.5.3-38-hotfix=>/tags

   Hope this helps,
   KIR

0

Unfortunately it appears to be a bug.  Here are my tag rules.

+:trunk=>tags
/branches/build-2.5.3-38-hotfix=>/tags

It didn't work either.  I've filed a bug here.

http://jetbrains.net/tracker/issue/TW-9549

0

As it turns out, the rules seems to be working. The confusion was caused by the fact that the new VCS labeling rules are taken into account only for the new builds. We will try to add a note into manual labeling dialog about that.

0

Please sign in to leave a comment.