TeamCity on Glassfish v3 exceptions


I am trying to get TeamCity working under Glassfish alongside Sonar. I have tried Tomcat but it seems to have have memory problems whereas Glassfish has no issues with memory.

Whilst trying to start (after a successful deployment) TeamCity 5.0.1 under Glassfish v3, i get the following exception:

Exception while loading the app : java.lang.Exception: java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: java.lang.NullPointerException

I have subsequently also tried TeamCity 4.5.6 too, which has much better luck in starting, but instead I get an exception within the app itself, once I've logged in. These are relating to loading Jasper class files. I have copied these from a TomCat installation into the class path for Glassfish to use, but then when I try again I get even more errors around symbols that don't exist (I don't have the details at hand right now but can produce them if necessary) in Jasper.

Therefore, is it possible to deploy TeamCity on to a Glassfish v3 container and how is this done? Am I missing some aspects of the installation?

Simon Paulger

1 comment
Comment actions Permalink

Glassfish is not supported by TeamCity at the moment, please use Tomcat.


Please sign in to leave a comment.