Teamcity NCover reports

I have installed NCover on the same system running TeamCity. I've also configured the default parameters for NCover on the build runner. When Teamcity builds my project, I'm not getting a Code Coverage report tab. Any suggestions?

3 comments
Comment actions Permalink

Hello Scott,

What version of TeamCity do you use? Can you please list your NCover settings?
There was an issue with start NCover x64 fixed in 5.1.4 version (please refer to http://youtrack.jetbrains.net/issue/TW-11808).

Thanks,
Marina

0
Comment actions Permalink

The version of TeamCity is  Version 5.1.4 (build 13550.

For the NCover settings (in TeamCity, is there another place?), I have this:

.Net Coverage Tool : NCover 3.x

.Net Runtime: .Net Framework 2.0 (our project is 3.5)
     Version : Native

Path to NCover 3: c:\program files\ncover (I tried the TeamCity variables, e.g. %system.ncover.v3.x64.path%, but it says that path does not exist)

NCover Arguments : //ias .*

NCover Reporting Arguments: //or FullCoverageReport:Html:{teamcity.report.path}

0
Comment actions Permalink

Hello Scott,

Please set version x86/x64 for .Net Runtime option. Also add environment property "teamcity.agent.dotnet.debug" with value "true" and run build. Attach build log and log files stored in <TeamCity agent>/temp/buildTmp/TeamCity.NET folder.


Thanks in advance,
Marina
0

Please sign in to leave a comment.