Error creating listener of type 'JetBrains.BuildServer.NAntLoggers.NAntListener' - Teamcity 5.1.4 w/ nant 0.85

Recently upgraded to TeamCity 5.1.4, and now builds are failing. I have tried:

1. upgrading nant to 0.90 alpha 1
2. reinstalling the build agent manually.

Still not resolved. Below is complete output from build log (error in bold).

Any help would be appreciated.

Cheers,

C.

Build 'WCRI.COOP.Member :: WCRI.COOP.Member.Build' #1.4.13
Started 'Thu Sep 09 22:19:07 EDT 2004' on 'MJOLLNIR' by 'you'
Finished 'Thu Sep 09 22:20:00 EDT 2004' with status 'ERROR Failure'
TeamCity URL http://mjollnir:81/viewLog.html?buildId=562&buildTypeId=bt2

[22:19:06]: bt2
[22:19:06]: Checking for changes
[22:19:07]: Clean build enabled: removing old files from C:\AUTOBUILD\WCRI\WCRI.COOP.Member.Build
[22:19:12]: Checkout directory: C:\AUTOBUILD\WCRI\WCRI.COOP.Member.Build
[22:19:12]: Updating sources: server side checkout...
[22:19:12]:  [Updating sources: server side checkout...] Will perform clean checkout
[22:19:12]:  [Updating sources: server side checkout...] Clean checkout reasons
[22:19:12]:  [Clean checkout reasons] Checkout directory is empty or doesn't exist
[22:19:12]:  [Clean checkout reasons] "Clean all files before build" turned on
[22:19:12]:  [Updating sources: server side checkout...] Transferring cached clean patch for VCS root: wcri.coop.vcs
[22:19:33]:  [Updating sources: server side checkout...] Repository sources transferred: 115.23Mb total
[22:19:33]:  [Updating sources: server side checkout...] Average transfer speed: 5.48Mb per second
[22:19:33]:  [Updating sources: server side checkout...] Removing C:\AUTOBUILD\WCRI\WCRI.COOP.Member.Build
[22:19:33]:  [Updating sources: server side checkout...] Updating C:\AUTOBUILD\WCRI\WCRI.COOP.Member.Build
[22:20:00]: NAnt output:

[22:20:00]: NAnt 0.85 (Build 0.85.2478.0; release; 14/10/2006)
[22:20:00]: Copyright (C) 2001-2006 Gerry Shaw
[22:20:00]: http://nant.sourceforge.net
[22:20:00]: For more information regarding the cause of the build failure, run the build again in debug mode.
[22:20:00]: BUILD FAILED
[22:20:00]: Error creating listener of type 'JetBrains.BuildServer.NAntLoggers.NAntListener'.
[22:20:00]:     Exception has been thrown by the target of an invocation.
[22:20:00]:         An XML comment cannot contain '--', and '-' cannot be the last character. Line 12, position 98.
[22:20:00]: Try 'nant -help' for more information
[22:20:00]: Publishing artifacts
[22:20:00]:  [Publishing artifacts] Paths to publish: [teamcity-info.xml]
[22:20:00]:  [Publishing artifacts] Publishing files
[22:20:00]: Build finished

1 comment

Please try running nant with debug options enabled to see more details of your issue.
Will NAnt work if you try running sample hello-world build script?

To enable debug, add:
-debug+
to the additional command line arguments section.

Do you use custom NAnt arguments? Please attach screenshot of your NAnt setting.

TeamCity is compatible with NAnt 0.86 and newer. I believe the oldest supported version of NAnt is "nant-0.85-nightly-2006-04-30"

0

Please sign in to leave a comment.