Command Parameters with Command Line build runner not correctly processed


We have converted our TeamCity setup from release 4.5 to 6.0.  There were a few quirks, but we got through most of them.

One of our projects involves running a TeamCity RSS feed through a homemade application, feeding it the RSS feed address as a parameter.  Unfortunately, the application does not receive the parameter correctly.  Actually, we are passing it two, but the application only receives a part of the first one.

Here is how it is:

Runner Type: Command Line


Command executable: IpPowerManagerApplication.exe

Command parameters: http://vmmobuild01/httpAuth/feed.html?projectId=project39&itemsType=builds&buildStatus=successful&buildStatus=failed&userKey=feed&itemsCount=250

Instead of receiving the two parameters, the application receives only http://vmmobuild01/httpAuth/feed.html?projectId=project39.  Looks like the parameters string is truncated at the first '&' character.  I tried enclosing the first parameter between quotes, to no avail.

There should be a way to use this string as a parameter.


Test code snipet:
          Console.WriteLine("args num: " + args.Length);
          Console.WriteLine("args[0]: " + args[0]);


[12:35:02]: Failure

[12:35:02]: args num: 1

[12:35:02]: args[0]: http://vmmobuild01/httpAuth/feed.html?projectId=project39
Comment actions Permalink

I already tried that.

I tried enclosing the first parameter between quotes, to no avail.

actually, I meant double quotes.  Maybe I should try single quotes, even if I doubt it would work any better.

Comment actions Permalink

Well, I'll be damned.

I tried with double (2) double quotes  "" as you put in your example, and it worked.



Please sign in to leave a comment.