Default agent is unable to connect to the server due to "400 Bad request"

Playing with TeamCity I have accidently removed the default agent. But it seems that actualy it still resides on the disk. I tried to run it again to see what happens, but it didn't lead me to recovery of agent. So I decided to make a fresh start. I stopped server and removed TeamCity Folder (data folder was inside). Then I installed it again. After having created my project again I've noticed that there still no default agent. So I decided to look into logs and found that:

[2011-09-12 18:19:40,834]   WARN - buildServer.AGENT.registration - Call http://localhost:8111/RPC2 buildServer.registerAgent3: org.apache.xmlrpc.XmlRpcClientException: Server returned incorrect status code: 400 Bad Request
[2011-09-12 18:19:40,835]   WARN - buildServer.AGENT.registration - Connection to TeamCity server is probably lost. Will be trying to restore it. Take a look at logs/teamcity-agent.log for details (unless you're using custom logging).

What can I do with this to make the default agent be connected to server?

There is some point I have to clarify: on last installation had "authorizationToken=" set to some tricky value. But now it is empty. Despite the comments say that "It is automatically generated and saved on the first agent connection to the server." it did not happen. May the absence of this token influence troubles with connecting?

I have attached my logs for either server or agent.

Thanks in advance.

1 comment
Comment actions Permalink


Sorry for late reply.

TeamCity cannot find its configuration in SQL database, so the server was switched to a maintenance mode.
In this mode it cannot accept connections from agents, so they get "400 Bad Request" error.

If the database should be re-created from scratch, then administrator can do it from web interface.


Please sign in to leave a comment.