Cannot successfully do an remote run via command line tool


I am trying to use the command line tool to trigger a remote run on our teamcity server, but seems to be unlucky, the tool always returns an error, is there anybody who can help on this? I'm still not aware of what is wrong.

My perforce server uses a proxy tunnel, and teamcity server version is 9.0.4 (build 32407) , thanks a lot!!



My local folder structure looks like:


The error log:

C:\Users\zli87\Downloads>java -jar tcc.jar run --host -m "remote" -c TestPreFlight Manifest.txt
[Connecting to "" TeamCity Server] started
[Connecting to "" TeamCity Server] done
[Logging in] started
[Logging in] done
[Collecting changes] started
[Collecting changes] Collected 1 files for Remote Run
[Collecting changes] done
[Mapping local files to TeamCity] started
[Mapping local files to TeamCity] run: error
java.lang.StringIndexOutOfBoundsException: String index out of range: -1
        at java.lang.String.substring(Unknown Source)
        at com.jetbrains.teamcity.resources.FileBasedMatcher.getMatching(
        at com.jetbrains.teamcity.resources.TCWorkspace.getTCResource(
        at com.jetbrains.teamcity.command.RemoteRun.getTCResources(
        at com.jetbrains.teamcity.command.RemoteRun.execute(
        at com.jetbrains.teamcity.command.CommandRunner.main(


1 comment
Comment actions Permalink

After digging into the source codes, found this trends to be a bug if file names instead of folder names are configued in VCS root mapping. The problem will be solved after I changed Manifest.txt to Test which is a folder containing Manifest.txt. Hope this helps others who meet the same issue.



Please sign in to leave a comment.