Configure TeamCity to Use Proxy Server for Outgoing Connections

Not able to get steps to perform Configure TeamCity to Use Proxy Server for Outgoing Connections on Projects — TeamCity

TeamCity ProfessionalVersion 2017.1.3 (build 46961)
 
Please assit
 
Thanks

 

6 comments
Comment actions Permalink

Hi,

The steps are described here: https://confluence.jetbrains.com/pages/viewpage.action?pageId=74845225#HowTo...-ConfigureTeamCitytoUseProxyServerforOutgoingConnections

Please take into account that some actions, such as some VCS checks, or the build agents, run on separate processes, and thus don't use this proxy configuration. If this is the case, please expand exactly on what you need and then we might be able to help.

0
Comment actions Permalink

This is not working when I'm trying to setup a new Connection in Project Settings >> Connections. 

Creating a new Docker Registry connection does NOT use the proxy settings 

Log

https://gist.github.com/zetta/26f2fc84930626de6695e5de11ed39d1

Usually debug shows the proxy chain in the logs, but not for this one. 

 

This is already included in the properties.

 

http.nonProxyHosts=....
http.proxyHost=proxy
http.proxyPort=8888
https.nonProxyHosts=....
https.proxyHost=proxy
https.proxyPort=8888
java.net.useSystemProxies=true
proxyset=true
1
Comment actions Permalink

Hi,

 

Indeed, this doesn't work with the Docker Registry. The docker registry connection will be performed via the docker command, and thus TeamCity settings will not apply for it. You will need to configure your local docker installation to use a proxy.

0
Comment actions Permalink

There is a problem when finishing the build to report the build status,success or fail,often connetction failed.it's because net is limit.how to use proxy in us to report status?

 

0
Comment actions Permalink

zetta were you able to solve this? I have the same problem but I dont understand the answer of Denis Lapuente becasue I have a Kubernetes deployment and inside my Server there is no docker installation.

Thanks in advance.

PS: Should I configure the proxy for the Agents instead of Server?

0
Comment actions Permalink

Emilio Sosa where to configure those settings depends on what actions you are trying to make. Please take into account that when this thread started kubernetes was not supported, and the initial message was generic. 

 

If the connection is being started by the teamcity process, you will need to set the proxy settings as detailed in the article. If the connection is being started by an external process (such as for docker registry calls), then that external process is the one which needs to be configured to use it. Kubernetes allows to set up settings for proxy usage, so you would need to check with the kubernetes documentation if you need assistance on using it. 

0

Please sign in to leave a comment.