AGENT UPDATE FAILED: Problems unpacking zip

Answered

Hey all

I just installed 10.0.2 and the agent is Disconnected

And during the update the following appears in the log. Excuse the formatting  : )

C:\TeamCity\BuildAgent\plugins\dotnet-tools\clt-bin\ExternalAnnotations\Misc\Caliburn.Micro[2017-01-05 13:56:14,394]   WARN - gentUnpackingPluginJarSearcher - Failed to unpack plugin: "C:\TeamCity\buildAgent\plugins\dotnet-tools-agent.zip": jetbrains.buildServer.agent.plugins.files.PluginUnpackException: Failed to unpack entry from "C:\TeamCity\buildAgent\plugins\dotnet-tools-agent.zip" to "C:\TeamCity\buildAgent\plugins". Error unpacking "dotnet-tools/clt-bin/ExternalAnnotations/Misc/Caliburn.Micro/" to "C:\TeamCity\buildAgent\plugins\dotnet-tools\clt-bin\ExternalAnnotations\Misc\Caliburn.Micro": java.io.IOException: Failed to create directory: C:\TeamCity\buildAgent\plugins\dotnet-tools\clt-bin\ExternalAnnotations\Misc\Caliburn.Micro

I have even copied the zip file and tried to unpack it manually and winzip even gives an error ???

Severe Error:  Not permitted or able to create an output directory.

Any help would be welcome

Thanks

Aidan

 

 

 

 

1 comment
Comment actions Permalink

I solved this is a security issue where the folder name contains MICRO virus software denies the creation of folder with .micro in the name. My next question is there a work around for this as changing the security run is opening up a security weakness

0

Please sign in to leave a comment.